Collapse column

Autor Thema: Werte links auslesen und dann rechts listenartig ausgeben ohne Nullen  (Gelesen 367 mal)

Offline Stefan

  • Newbie
  • *
  • Beiträge: 17
    • Profil anzeigen
  • Office-KnowHow: Anfänger
  • VBA-KnowHow- : Ohne
  • Version [Office] : Office 2010
Werte links auslesen und dann rechts listenartig ausgeben ohne Nullen
« am: Januar 12, 2019, 10:04:58 Vormittag »
Hallo,

wer kann mir dabei helfen !!!

Folgendes Problem habe ich es stehen links in einer Tabelle Zahlen mit verschiedenen Werten dabei sind auch auch Nullen.
Ich möchte diese Werte rechts wieder ausgeben und das hintereinander jedoch ohne Nullen .Die Nullen soll EXEL überspringen bis wieder eine Zahl größer ist als Null ???
Habe eine Exel Datei hochgeladen ;-)

Vielen Dank im voraus  ;D

Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden und Dein Anliegen in Auftrag geben.
>>> Schnell und einfach ein unverbindliches Angebot anfordern. Per E-Mail an anfrage@excel-inside.de oder per Online-Formular
<<<

!!! Wichtige Information
!!! Dieses Forum kann aus technischen Gründen leider nur bis maximal September 2019 in der Form betrieben werden.
Das neue Forum steht bereits unter https://forum.excel-inside.de uneingeschränkt zur Verfügung. Es wird empfohlen, neue Fragen direkt dort zu posten.

Bitte verwendet somit schnellstmöglich das neue Forum - Vielen Dank für euere Unterstützung

Offline maninweb

  • Global Moderator
  • Hero Member
  • *****
  • Beiträge: 1.050
    • Profil anzeigen
    • Excel Formula Translator
  • Office-KnowHow: Experte
  • VBA-KnowHow- : Sehr gut
  • Version [Office] : Office 2016
Antw: Werte links auslesen und dann rechts listenartig ausgeben ohne Nullen
« Antwort #1 am: Januar 12, 2019, 10:26:48 Vormittag »
Hallo,

in E3 folgende Formel und dann AutoAusfüllen ...

Code: Visual Basic
  1. =WENNFEHLER(INDEX($B$3:$B$31;AGGREGAT(15;6;(ZEILE($B$3:$B$31)-ZEILE($B$2))/($B$3:$B$31<>0);ZEILE()-ZEILE($B$2)));"")

Gruß
Microsoft Excel Expert · Microsoft Most Valuable Professional (MVP) from 01/2011 - 06/2019
https://de.excel-translator.de :: Online Excel-Formel-Übersetzer :: Alle Übersetzungen der Excel Funktionen & Fehlerwerte

Online Calderon

  • Jr. Member
  • **
  • Beiträge: 76
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2016
Antw: Werte links auslesen und dann rechts listenartig ausgeben ohne Nullen
« Antwort #2 am: Januar 12, 2019, 10:28:57 Vormittag »
http://www.excelformeln.de/formeln.html?welcher=43
angepasst auf die Beispieltabelle:
=WENN(ZEILE(B3)>ANZAHL2(B:B);">0";INDEX(B:B;KKLEINSTE(WENN(B$3:B$1000>0;ZEILE($3:$1000));ZEILE(B1))))

Als Matrixformel speichern (STRG+Shift+Enter).

Online gmg-cc

  • Hero Member
  • *****
  • Beiträge: 1.317
    • Profil anzeigen
    • Meine Webseite
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Gut
  • Version [Office] : Office 2016
Antw: Werte links auslesen und dann rechts listenartig ausgeben ohne Nullen
« Antwort #3 am: Januar 12, 2019, 10:30:16 Vormittag »
Moin,
für Power Query, -> http://www.excel-ist-sexy.de/power-query-das-add-in/ ist das eine Fingerübung ...  ;)
Importieren, alle Nullen durch "leer (null)" ersetzen lassen, null löschen, speichern. Hinweis: null ist wirklich leer, nicht ""
Andere Lösungen sind denkbar, insbesondere mit VBA.
Gruß
Günther

Online DL

  • Hero Member
  • *****
  • Beiträge: 806
  • {Irrtum / Versuch * Glaskugel}
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2016
Antw: Werte links auslesen und dann rechts listenartig ausgeben ohne Nullen
« Antwort #4 am: Januar 12, 2019, 10:30:56 Vormittag »
Wir sehen uns!
... Detlef
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()

Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden und Dein Anliegen in Auftrag geben.
>>> Schnell und einfach ein unverbindliches Angebot anfordern. Per E-Mail an anfrage@excel-inside.de oder per Online-Formular
<<<

!!! Wichtige Information
!!! Dieses Forum kann aus technischen Gründen leider nur bis maximal September 2019 in der Form betrieben werden.
Das neue Forum steht bereits unter https://forum.excel-inside.de uneingeschränkt zur Verfügung. Es wird empfohlen, neue Fragen direkt dort zu posten.

Bitte verwendet somit schnellstmöglich das neue Forum - Vielen Dank für euere Unterstützung

Offline Stefan

  • Newbie
  • *
  • Beiträge: 17
    • Profil anzeigen
  • Office-KnowHow: Anfänger
  • VBA-KnowHow- : Ohne
  • Version [Office] : Office 2010
Antw: Werte links auslesen und dann rechts listenartig ausgeben ohne Nullen
« Antwort #5 am: Januar 12, 2019, 11:03:01 Vormittag »
Vielen Dank hat mir sehr geholfen  ;D ;D ;D

Frohes Neues Jahr wünsche ich euch !!!

Wenn du dich noch intensiver mit Excel beschäftigen möchtest, dann empfiehlt sich ein Online-Kurs,
in dem du sehr viel über Excel erfährst und das gelernte umgehend in der Praxis anwenden kannst.