Collapse column

Autor Thema: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen  (Gelesen 215 mal)

Offline edi

  • Newbie
  • *
  • Beiträge: 25
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2010
Hallo,

habe folgendes Anliegen:
- wenn in Tabellenblatt "Zusf. IS"  Zelle "B5" 100% steht, soll in Spalte "C"in den Zeilen "8:14" ein zugehöriger Text aus dem Tbellenblatt "Inneres Selbstbild-2" stehen
- gleiches soll gelten wenn "50%" oder eine andere Zahl steht
- Excel-Datei anbei

Gruß Eduard

Online steve1da

  • Hero Member
  • *****
  • Beiträge: 1.350
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #1 am: Januar 11, 2019, 10:55:20 Vormittag »
Hola,

Wenn-Dann-Sonst.
Das ist die normale Syntax. Du hast:
Wenn-Dann-Sonst;Wenn-Dann-Sonst
Das haut nicht hin und erzeugt#WERT.
Schau dir den Sverweis an:
https://www.online-excel.de/excel//singsel.php?f=9

Gruß,
steve1da

Offline edi

  • Newbie
  • *
  • Beiträge: 25
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #2 am: Januar 15, 2019, 09:01:45 Vormittag »
Hallo,

ich habe mich jetzt mit "SVERWEIS" etc. beschäftigt, habe mehrere Wege versucht und komme auf keine Lösung.

Mein letzter Ansatz mit Hilfstabelle für die "%" und der Formel "=WENN(SVERWEIS($B8;'Inneres Selbstbild-2'!$C$38;0)=I12;'Inneres Selbstbild-2'!C38)" bringt das Ergebnis: #NV

Mein Latein ist am Ende - Bitte um Hilfestellung, Danke.

Gruß Eduard

Online steve1da

  • Hero Member
  • *****
  • Beiträge: 1.350
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #3 am: Januar 15, 2019, 09:12:31 Vormittag »
Hola,

in deiner Datei steht doch sogar schon ein Sverweis mit korrekter Syntax, in M4.

Korrekt würde der Sverweis für dich lauten:

=SVERWEIS(B8;'Inneres Selbstbild-2'!$B$6:$C$54;2;0)
Gruß,
steve1d

Offline edi

  • Newbie
  • *
  • Beiträge: 25
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #4 am: Januar 15, 2019, 09:39:16 Vormittag »
Danke Steve,

hatte ich auch schon - auch statt der "0" mit "FALSCH" -> die erste Zeile des Textes erscheint, jedoch der Text der Zeilen danach (aus Inneres-Selbstbild-2) eben nicht, da hänge ich.

Gruß Eduard

Online steve1da

  • Hero Member
  • *****
  • Beiträge: 1.350
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #5 am: Januar 15, 2019, 09:47:25 Vormittag »
Hola,

du musst deine Prozentwerte in den Tabellen in jede Zelle schreiben (die kannst du ja mit weißer Schriftfahre "unsichtbar" machen). Ich hab dir das mal für die 50% dargestellt.

Gruß,
steve1da

Offline edi

  • Newbie
  • *
  • Beiträge: 25
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #6 am: Januar 15, 2019, 10:32:47 Vormittag »
Hallo steve,

super, hat geklappt. Ein Problem noch: wenn in einer Zeile kein Text vorhanden, dann folgt "#ZAHL!" -> möchte, dass dann nichts steht, leer bleibt.

Hast Du da noch einen Kniff?

Gruß Eduard

Online steve1da

  • Hero Member
  • *****
  • Beiträge: 1.350
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #7 am: Januar 15, 2019, 10:36:07 Vormittag »
Hola,

=wennfehler(FORMEL;"")

Gruß,
steve1da

Offline edi

  • Newbie
  • *
  • Beiträge: 25
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #8 am: Januar 15, 2019, 10:47:20 Vormittag »
Hallo steve,

super das klappt - recht herzlichen Dank.

Gruß Eduard

Offline edi

  • Newbie
  • *
  • Beiträge: 25
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #9 am: Januar 15, 2019, 19:00:51 Nachmittag »
Hallo steve,

brauche doch nochmal Deine Hilfe.
Bei Fertigstellung habe ich festgestellt, dass es doch nicht ganz klappt - in beiliegender Datei habe ich die Zellen "Gelb" markiert, die Formel ist hinterlegt.

Gruß Eduard

Online steve1da

  • Hero Member
  • *****
  • Beiträge: 1.350
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #10 am: Januar 16, 2019, 07:10:17 Vormittag »
Hola,

markier die Zellen mit den Formeln und wähle als benutzerdefiniertes Zellformat

Standard;;
Jedenfalls denke ich dass es das ist was du willst, da du keine konkrete Frage gestellt hast und mich mehr oder weniger raten lässt.

Gruß,
steve1da

Offline edi

  • Newbie
  • *
  • Beiträge: 25
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2010
Antw: wenn in Zelle 100% steht, soll in Zeilen/Spalte ein zugehöriger Text stehen
« Antwort #11 am: Januar 16, 2019, 08:20:19 Vormittag »
Hallo Steve,

Du hast richtig geraten - ich hatte schon die Formatierung "Standard" eingestellt, aber auf die Platzhalter ";;" habe ich nicht gedacht.

vielen Dank.

Gruß Eduard