Collapse column

Autor Thema: Office 2016 Ein Bezug - mehrer Werte  (Gelesen 85 mal)

Offline MatthiasK

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2016
Office 2016 Ein Bezug - mehrer Werte
« am: Dezember 07, 2018, 10:05:51 Vormittag »
Hallo,

kurz zu mir - meine Name ist Matthias und ich bereite für einen Online Store Feeds vor.
Aktuell möchte ich Warenkörbe auswerten.

Ich habe eine Tabelle mit Bestellnummern und Produkten. Ich benötige eine Formel, die mir für eine Bestellnummer alle dazugehörigen Produkte (nebeneinander) auswirft.

Beispiel im Anhang als Bild.

Ich habe schon diverse Index Formel ausprobiert und im Netz geschaut, bin aber immer gescheitert. Vllt. könnt Ihr mein Freitag retten.

Ich sage schon mal vielen Dank.

Grüße
Matthias

Online gmg-cc

  • Hero Member
  • *****
  • Beiträge: 1.241
    • Profil anzeigen
    • Meine Webseite
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Gut
  • Version [Office] : Office 2016
Antw:Office 2016 Ein Bezug - mehrer Werte
« Antwort #1 am: Dezember 07, 2018, 10:11:47 Vormittag »
Moin,
1. schau mal hier nach ...
2. Das ist der schlechtest denkbare Weg, denn sinnvolle Auswertungen sind nicht mit einer Kreuztabelle machbar
3. Das könnte mit Stichwort: Power Query (2010/13) aka Daten | Abrufen und transformieren (2016/365) machbar sein (kann ich wegen Punkt 1 nicht prüfen).
Gruß
Günther

Offline MatthiasK

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2016
Antw:Office 2016 Ein Bezug - mehrer Werte
« Antwort #2 am: Dezember 07, 2018, 10:19:16 Vormittag »
Moin,

vielen Dank, ich werde einen Blick darauf werfen.

--> ok, vertanden - Sorry.

Grüße
Matthias
« Letzte Änderung: Dezember 07, 2018, 10:21:54 Vormittag von MatthiasK »

Online steve1da

  • Hero Member
  • *****
  • Beiträge: 1.305
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2010
Antw:Office 2016 Ein Bezug - mehrer Werte
« Antwort #3 am: Dezember 07, 2018, 10:23:45 Vormittag »
Hola,

als Formellösung:

=WENNFEHLER(INDEX($B$2:$B$8;AGGREGAT(15;6;ZEILE($A$2:$A$8)-1/($A$2:$A$8=$E2);SPALTE(A1)));"")
Gruß,
steve1da

Offline MatthiasK

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2016
Antw:Office 2016 Ein Bezug - mehrer Werte
« Antwort #4 am: Dezember 07, 2018, 10:27:28 Vormittag »
Moin,

das ging wahnsinnig schnell.

Das sieht sehr gut aus und scheint auch gut zu funktionieren. Ich werde es mal mit einem großes Datensatz testen.

Auf jeden Fall Vielen Dank!!

Grüße
Matthias