Collapse column

Autor Thema: Office 2013: Office 2016 Feldinhalt mit einem Array vergleichen  (Gelesen 188 mal)

Offline LOBO0108

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2016
Office 2013: Office 2016 Feldinhalt mit einem Array vergleichen
« am: April 05, 2018, 12:47:26 Nachmittag »
Hallo Forum,

ich weiß nicht mehr weiter. Anfangs, dachte ich nicht, dass mich diese Funktion länger beschäftigt. Mittlerweile bin ich etwas schlauer:

Ich habe eine Tabelle, welche in einer Spalte das Ursprungsland ausweist. In einer 2. Tabelle (EU-Länder Spalte A1-A28) stehen sämtliche EU-Länder-Kürzel. In einer Spalte möchte ich abprüfen, ob das Land innerhalb der EU ist oder nicht. Ist es enthalten soll "J" ausgegeben werden, ansonsten "N".

Sämtliche Versuche mit z.B. =WENN(VERWEIS(J14;'EU-Länder'!$A$1:$A$28);"J";"N") werden mit einem #WERT! beantwortet. Wo ist mein Denkfehler? Weiß jemand Rat?

Markus

« Letzte Änderung: April 05, 2018, 13:07:32 Nachmittag von LOBO0108 »

Online steve1da

  • Hero Member
  • *****
  • Beiträge: 1.111
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2010
Antw:Office 2013: Office 2016 Feldinhalt mit einem Array vergleichen
« Antwort #1 am: April 05, 2018, 13:12:10 Nachmittag »
Hola,

=wenn(zählenwenn('EU-Länder'!$A$1:$A$28;J14);"J";"N")

Gruß,
steve1da

Offline LOBO0108

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Wenig
  • Version [Office] : Office 2016
Antw:Office 2013: Office 2016 Feldinhalt mit einem Array vergleichen
« Antwort #2 am: April 05, 2018, 13:23:58 Nachmittag »
Hallo steve1da,

DU hast mich gerettet - das war's. Vielen Dank.
Ich habe die Funktion in einem anderen Zusammenhang schon verschiedentlich verwendet. Ich bin jetzt jedoch nicht mehr draufgekommen.

Markus
« Letzte Änderung: April 05, 2018, 13:26:09 Nachmittag von LOBO0108 »