Collapse column

Autor Thema: Office 2016 Summe bilden, wenn Datum "abgelaufen"  (Gelesen 319 mal)

Offline UliG

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2016
Office 2016 Summe bilden, wenn Datum "abgelaufen"
« am: November 19, 2017, 09:12:56 Vormittag »
A Guten Morgen zusammen,

ich habe Spalte A mit unterschiedlichen Datumsangaben. Daneben in Spalte B stehen Werte (einfache Zahlen). Insgeasmt sind es etwa 20-30 Zeilen.
Ich möchte nun eine Summe aus den Werten in Spalte B bilden, wenn die Datumsangaben in Spalte A bezogen auf das aktulle Tagesdatum "abgelaufen" sind, d.h. das Datum in Spalte A ist älter als
das durch =Heute () erzeugte Tagesdatum.
Ich dachte. dass sei ein Fall für Summewenn (=SUMMEWENN($A$4:$A$21;"<=#C1";$B$4:$B$21) wobei sich C1 auf  =heute() also das Tagesdatum verweist.
Funktioniert aber leider nicht.
Wäre für eine Lösung dankbar (und mein Sonntag wäre gerettet :-).
Danke im Voraus für Mühen und Rat.
 
 


Online DL

  • Hero Member
  • *****
  • Beiträge: 603
  • {Irrtum / Versuch * Glaskugel}
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2016
Antw: Office 2016 Summe bilden, wenn Datum "abgelaufen"
« Antwort #1 am: November 19, 2017, 09:18:49 Vormittag »
Ich dachte. dass sei ein Fall für Summewenn (=SUMMEWENN($A$4:$A$21;"<=#C1";$B$4:$B$21) wobei sich C1 auf  =heute() also das Tagesdatum verweist.
Funktioniert aber leider nicht.


"<="&C1
Wir sehen uns!
... Detlef
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()

Offline UliG

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2016
Antw: Office 2016 Summe bilden, wenn Datum "abgelaufen"
« Antwort #2 am: November 19, 2017, 09:40:47 Vormittag »
danke für schnelle Reaktion. Leider geht es auch mit
(=SUMMEWENN($A$4:$A$21;"<="&C1";$B$4:$B$21) nicht.
Summe aus Spalte B bleibt 0.

Grüße

Online DL

  • Hero Member
  • *****
  • Beiträge: 603
  • {Irrtum / Versuch * Glaskugel}
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2016
Antw: Antw: Office 2016 Summe bilden, wenn Datum "abgelaufen"
« Antwort #3 am: November 19, 2017, 09:47:48 Vormittag »
Leider geht es auch mit
(=SUMMEWENN($A$4:$A$21;"<="&C1";$B$4:$B$21) nicht.


"<="&C1
Wir sehen uns!
... Detlef
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()

Offline UliG

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Mittelmäßig
  • Version [Office] : Office 2016
Antw: Office 2016 Summe bilden, wenn Datum "abgelaufen"
« Antwort #4 am: November 19, 2017, 09:54:43 Vormittag »
oh ja, es geht. Die Zellenformate in Spalte A waren nicht korrekt.
Danke DL für Hilfe und Lösung. Wünsche Dir einen schönen Sonntag.
Grüße

Offline Jever

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Ohne
  • Version [Office] : Office 2016
Antw: Antw: Antw: Office 2016 Summe bilden, wenn Datum "abgelaufen"
« Antwort #5 am: November 26, 2017, 12:48:48 Nachmittag »
Zitat von: DL link=topic=52011.msg60430#msg60430 =1511081268
Leider geht es auch mit
(=SUMMEWENN($A$4:$A$21;"<="&C1";$B$4:$B$21) nicht.


"<="&C1

Offline Jever

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
  • Office-KnowHow: Fortgeschritten
  • VBA-KnowHow- : Ohne
  • Version [Office] : Office 2016
Antw: Office 2016 Summe bilden, wenn Datum "abgelaufen"
« Antwort #6 am: November 26, 2017, 12:53:24 Nachmittag »
Meine Frage: Welche Funktion haben hier die Anführungszeichen bei "<="&C1, es handelt sich doch nicht um "Text" sondern um eine Operationsanweisung?
Gruß
E

Online lupo1

  • Full Member
  • ***
  • Beiträge: 117
    • Profil anzeigen
  • Office-KnowHow: Anfänger
  • VBA-KnowHow- : Ohne
  • Version [Office] : Office 2010
Antw: Office 2016 Summe bilden, wenn Datum "abgelaufen"
« Antwort #7 am: November 26, 2017, 13:39:04 Nachmittag »
Excel wird damit ein sogenannter unärer (einseitiger) Vergleich mitgeteilt. Das funktioniert so seit 35 Jahren (Lotus, dann Excel) im Kriterienbereich des Spezialfilters, und selbst beim Autofilter ist es so.

"Unär": Das, was verglichen werden soll, steht schon aufgrund der Position fest. Deswegen war der olle Kriterienbereich für unäre Formulierungen auch immer schon auf 2 Zeilen angewiesen - auch wenn zweiseitige Formulierungen sowie Kriteriumsverknüpfungen in nur einer Zelle auch immer schon möglich waren.
MfG Lupo1 (und natürlich gern auch Hallo!)